Test Data missing error -public wpt instance for scripted tests

Hi All,
I am exploring the scripted test using the public instance. Somehow I am not able to execute any scripted test successfully. Please find the below script that I am trying to execute either in front end or usnig Marcel Duran’s Node JS wrapper. In either ways I am unable to execute a scripted test successfully. Request your support regarding this.
Script tried in http://www.webpagetest.org [front end]
logData 0
navigate http://www.google.com
logData 1
setValue id=lst-ib value=Java
submitForm name=f

Script tried using the NodeJS client
var WebPageTest = require(‘C:\Users\sridh\node_modules\webpagetest\lib\webpagetest’);
var wpt = new WebPageTest(‘https://www.webpagetest.org/’, ‘’);
wpt.runTest(‘https://google.com’, {
connectivity: ‘Cable’,
location: ‘Dulles:Chrome’,
firstViewOnly: true,
runs: 1,
video: false
}, function processTestRequest(err, result) {
console.log(err || result)

If you are running using the Node API, you have to create the script as an object, something like
{command1: ‘value1’},
{command2: 123},
{command3: [‘value1’, ‘value2’, … , ‘valueN’]},


then create pass that string into WebPageTest.scriptToString(script); and then pass it to the runTest method.
This question actually does not belong to this forum. Should be opened in the node api repo.

Hi AbhaGupta,
Thanks a lot for the reply!! I tried as per your suggestion getting Invalid script error.
Please find the attached screenshot of the script that I am trying to execute but getting the below. Please let me know what is wrong with the script.
“statusCode”: 400,
“statusText”: “Invalid Script (make sure there is at least one navigate command and that the commands are tab-delimited). Please contact us if you need help with your test script.”