Unable to play recorded videos

I set up 3 test agents:

  1. Medium instance ami-92320ed7(California)
  2. Large Instance ami-92320ed7(California)
  3. Medium instance ami-4f202626(Virginia)

This is version number from /work/update.ini:

I see that the video files are generated under /work/video but i cannot play them in a browser. When i click on “Watch Video” i see a screen which says “Your video will be available shortly. Please wait…”.


Can you tell us where these videos are located? What software are you using and what platform?

These videos are located on the private instance server. This is the path where i see the compressed videos with timestamps:/webpagetest/work/video. WPT private instance is installed on a linux machine.

The test agents are installed on Windows 2008.

Have you tried playing them in on other online platforms? Let me know which ones and if they worked or not.

What do you mean by other “online platforms” ?
I have the infrastructure set up on AWS.

I mean on other servers, other websites or through other devices.

I tried different test agents(tried on 3 different agents i only have windows 2008 configured), different browsers(Chrome, Firefox, IE 10/11), different sites(google,facebook)… In all the cases i see the same error. Upon clicking on the video link i see this error: “Your video will be available shortly. Please wait…”.

I think the problem is that there are no urlblast agents configured and the newer wptdriver agent doesn’t render videos (the plan is to move all rendering to the server). You’ll need at least one of the older AMIs running to be able to render videos for now (it doesn’t necessarily need to do actual testing but it does need to connect to be able to render video).

Thanks Patrick !! I got the videos working now.

I am getting a message : 200 Stream Not found when trying to play video from a Private local instance.