No video recorded

I finally managed to setup my private webpagetest instance, using this guide and test machine located in EC2, built from AMI provided.

Locations was tricky part, but it was solved - only one thing is left: no video recorded.
In http://myserver/install i see:
No test agents are configured to render video
So, it seems that the problem is on agent side
I’ve used this AMI - ami-54291f49

But, I could not figure out how to configure agent. According to guide - I need only AviSynth installed - and it is installed.


Same problem for me :frowning:

Anyone have the same problem? Or maybe there is some additional data should be provided?
Could you please help me?

What other information is returned from the /install page?

See the following post:

It looks like the issue is that the ffmpeg that comes with Ubuntu normally does not have lib x264 compiled-in and that is needed for server-side rendering. I have added a check for that post-2.16 which will hopefully help in tracking down the issue.

I am running on CentOs
FFmpeg version 0.6.5, Copyright (c) 2000-2010 the FFmpeg developers
built on Jan 29 2012 17:52:15 with gcc 4.4.5 20110214 (Red Hat 4.4.5-6)
configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --incdir=/usr/include --disable-avisynth --extra-cflags=’-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC’ --enable-avfilter --enable-avfilter-lavf --enable-libdc1394 --enable-libdirac --enable-libfaac --enable-libfaad --enable-libfaadbin --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libx264 --enable-gpl --enable-nonfree --enable-postproc --enable-pthreads --enable-shared --enable-swscale --enable-vdpau --enable-version3 --enable-x11grab
libavutil 50.15. 1 / 50.15. 1
libavcodec 52.72. 2 / 52.72. 2
libavformat 52.64. 2 / 52.64. 2
libavdevice 52. 2. 0 / 52. 2. 0
libavfilter 1.19. 0 / 1.19. 0
libswscale 0.11. 0 / 0.11. 0
libpostproc 51. 2. 0 / 51. 2. 0

I recompiled FFMPEG anew using this guide -, and still have no luck - whenever I try to watch video, it tells me that stream is not found on path

Here is full output of /install page:
WebPagetest 2.16 Installation Check


PHP version at least 5.3: 5.4.27
GD Module Installed: yes
FreeType enabled for GD (required for video rendering): yes
zip Module Installed: yes
zlib Module Installed: yes
curl Module Installed: yes
php.ini allow_url_fopen enabled: yes
APC Installed: yes
SQLite Installed (for editable test labels): yes
php.ini upload_max_filesize > 10MB: 11M
php.ini post_max_size > 10MB: 11M
php.ini memory_limit > 256MB or -1 (disabled): 257M
System Utilities

ffmpeg Installed (required for video): yes
ffmpeg Installed with scale and decimate filters(required for mobile video): Not Detected (optional)
imagemagick compare Installed (required for mobile video): yes
jpegtran Installed (required for JPEG Analysis): yes
exiftool Installed (required for JPEG Analysis): NO (optional)

{docroot}/tmp writable: yes
{docroot}/dat writable: yes
{docroot}/results writable: yes
{docroot}/work/jobs writable: yes
{docroot}/work/video writable: yes
{docroot}/logs writable: yes
{docroot}/tmp on tmpfs: NO (optional)
Test Locations

No test agents are configured to render video

Frankfurt : Frankfurt (IE11, Chrome, FF, Safari)
Frankfurt_wptdriver : Frankfurt Chrome, FF, Safari - 1 agents connected

Can you check “ffmpeg -version” and “ffmpeg -filters”? I’m wondering why there is the “not detected” in the second ffmpeg check (though those are only needed for mobile video).

Do you get filmstrips and it’s just when you go to render a video that it fails?

Thank you.
It was my fault - though I recompiled ffmpeg - it was not accessible to apache (as guide, I used, places it in /root/bin).
Now video is rendered ok