Cannot set up agent on Windows 7 machine

Hi Patrick,

I’m trying to set up the agent on the Windows 7 machine, and I followed your steps. A problem occurred when I tried to install the DUMMYNET ipfw driver. After I selected the dummynet folder, the ipfw+dummynet service doesn’t show up (and it says there is no drivers to install). Is there a way around this problem?


Sounds like you are installing on 64-bit Windows. Dummynet is a 32-bit driver and requires 32-bit Windows (for now, working on getting 64-bit available right now).

Thanks :slight_smile:


is there any news on a win7 64-bit release? I’m slightly confused as the installer has a folder for 64-bit, but I cannot get the application to work…

What installer? There shouldn’t be a 64-bit one yet.

We have the driver building and working but we are having troubles signing the driver in a way that works for Windows. 64-bit windows requires signed drivers and the only way to bypass it is to F8 during boot (every time you reboot). We have code signing keys and have tried a bunch of different ways but the kernel has yet to accept it. Hopefully we’re only one stupid tweak away from having it working but it’s that close.

And by “we”, Luigi Rizzo has done all of the hard work and got the driver working, I’m the one fumbling with getting it signed. If anyone has experience code-signing NDIS drivers help would be appreciated.

The one here: , which unpacks to a /binary and /binary64 folder…

I wish I could help, but know nothing about driver signing, sorry!! I will ask around and see I know anyone else who know…

Ahh, yes - that is the driver we’re currently working on. It’s functional but unsigned (so it has the problem where you need to manually intervene during system boot).

Is there any update on this. Trying to install the agent on windows 7 and getting the unable to find any drivers message

Quite literally JUST released 2.9 which includes a 64-bit build of dummynet -