N/A everywhere but "First Byte Time"


I came a cross a site using the same e-commerce CMS I do, and it is very fast.

I ran a test to see how he optimized it, and got some wierd results: [url=http://www.webpagetest.org/result/130826_PX_3CE/]http://www.webpagetest.org/result/130826_PX_3CE/[/url]. Everything but the first column, “First Byte Time”, shows N/A, and Error: 404 is displayed in results.

Can someone please help me to interpret the these results?

Thanks in advance!

That’s because the server responded with a 404 (and a 404 error page) for the URL you tested: http://www.webpagetest.org/result/130826_PX_3CE/1/details/#request1

Do you have your 404 handler set to return the normal home page? I’m assuming you should really be testing http://www.star500.com/shop/index.html

I tried testing http://www.star500.com/shop/index.html and got the same result: WebPageTest Test - Running web page performance and optimization tests... .

As I already stated in my post, this is not my site, so I am not sure if they have “404 handler set to return the normal home page” on it.

Sorry, got a bit mixed up about whose site you were testing. They are returning 404’s for the main page (and including page content). Browsers will still display the page but WebPagetest will fail the test as soon as it sees that it is a 404.

I’d be amazed if they get any search traffic unless they are doing something different for bots - it’s pretty fundamentally broken.

Your best bet is to load up the page in something like Chrome’s dev tools and look at the waterfall.

That said, if their optimizations are for the first byte time, you’re not going to be able to see what they are doing from the outside.

Thank you so much for your help and fast response!