Need help in finding ffmpeg for Private Instance install

I am trying to setup a private instance of WebPagetest on Windows 7 (32-bit) machine. I have installed the ffmpeg package files on my machine. However the install check which I ran to test my private instance, came up with a second instance of ffmpeg missing. I cannot find this second instance of ffmpeg (Yellow marker under System Utilities header in the attached screenshot) which I would like to install to clear the install issues. Can someone help me out here?

I have attached the screenshot after running the install script below.


Can someone kindly mail me the ffmpeg file in question for a windows 7 32-bit machine. I have PHP version 5.4.7 installed on it?

I will appreciate it very much.


I looked at the index.php script in the install directory and tried to debug it. This script gives the following command to the system:

C:\ffmpeg -filters ( line # 337: $retStr = exec($command, $output, $result);

The output from the command on my system makes the following variables true in the script:
$fps = true;
$scale = true;
$decimate = true;

However the $ver comes out to be
$ver =N-50911-g9efcfbe instead of ‘1’

So the test on line 352 fails and $ret becomes false

352: if (intval($ver) == 1 && $fps && $scale && $decimate)

Hence the return value is false:

362: return $ret;

Is this correct? Seems like all the functionality is there but the version number has changed. The output from the command on line 337 puts out the following values for the features above:

ffmpeg version N-50911-g9efcfbe Copyright (c) 2000-2013 the FFmpeg developers


decimate V->V Remove near-duplicate frames.
fps V->V Force constant framerate
scale V->V Scale the input video to width:height size and/or convert the image format.

Someone please let me know if the version number matters and why are we checking for version 1?


On Windows I usually grab the static builds from here: which looks like what you have and should be fine (I’ll see about updating the version check).

We are chacking for version 1 because the decimate filter changed in version 2 and we rely on it’s output to be able to de-dupe video frames and still get the timecode of the individual frames (kind of insane that ffmpeg doesn’t support that but it doesn’t).

As you mentioned, I understand that I have the requisite ffmpeg file installed. I will wait for the update to the index.php script from you and then run index.php file to declare success with this configuration install.

Thanks for your reply!