need help with hosted version

Dear Webpagetest,

First of all, I would like to thank you for the development efforts to make such an awesome application available to all of us!

A couple months ago, I was able to get a full hosted pagetest running with an linux+apache frontend, and windows7 + IE8 running the actual tests. I believe this was with version 1.6

I’ve restarted a project to get this up and running again on a new machine with the latest version 1.9.
I have so far been unsuccessful, and I don’t know if its a simple misconfiguration or other error.

Here’s my setup:
Linux + apache running the latest “Web Site” content (version 1.9). When I create a “new test” I see the .url file being created on the webserver in the …/work/jobs/test/100714_T.url file.
I’m fairly confident the webserver side is properly configured, and that the webserver user has proper permissions to create the needed local files (*.url; lock.dat; times/, etc…)

For the Client (desktop) portion running the URLBlast pieces, I’ve set up a Windows Server OS running on Amazon’s EC2 platform.
Specifically, I’m using this AMI: amazon/Windows-Server2008-i386-Base-v103
WIndows Server 2008 32-bit

I downloaded and installed the latest pagetest plugin for IE:
AOL Pagetest
That and CIEhook Object ( are both enabled and are the only plugins installed.
IE is running version 8.0.6001.18904

When I First ran the latest 1.9 version of webtest, The only thing I see working is the URLBlast application doing a GET request to the webserver:
“GET /work/getwork.php?location=Test&key=TestKey123 HTTP/1.1” 200 - “-” “urlblast”

The client is running the URLBlast program and writing to the log file, but nothing useful is being printed out. I see the .url file get picked up and moved on the server, but no tests are actually run on the windows machine. I played around with the urlblast.ini settings quite a bit, specifically the “browser” option, commenting it out, leaving it at just browser=pagetest.exe, as well as the explicit PATH to pagetest.exe on disk. Still nothing…

I rolled back the URLblast /pagetest version to 1.6 which has worked in the past for me.
SInce then I’m getting a bit more useful feedback in the logs.
When I run the URL test program with either:
browser=pagetest.exe OR
browser=C:\Users\Administrator\Desktop\Web Site\PageTest.exe
I see this in the logs:
2010/07/14 21:09:01 -1 0 1 0 0 URLBlast Started
2010/07/14 21:09:01 -1 0 1 9 6 OS Version Windows Server 2008 Service Pack 2 (6.0.6002 SP 2.0 Suite 0x00000190 Product 3)
2010/07/14 21:09:01 -1 0 1 11 8 IE Version 8.0.6001.18904
2010/07/14 21:09:01 -1 0 1 12 209 URLBlast Version
2010/07/14 21:09:33 -1 0 1 18 0 Error Failed to launch browser ‘?#?$system cannot find the file specified.’ - pagetest.exe

It looks like its still running the newer URLBlast?, or is that the plugin version?

When I comment out the browser option in urlblast.ini,
The logs show this:
2010/07/14 21:10:44 -1 0 1 3 0 Browser Launched Cleared Cache-Run_1^
2010/07/14 21:11:05 -1 0 1 3 0 Browser Launched Cached-Run_1^

A browser window opens, but hangs at the about:blank page indefinitely.

When I try to manually run the AOL pagetest plugin, it doesn’t seem to work at all.
No output is seen in the pagetest window, nothing, completely blank.
I’ve tried changing the “internet security” settings to be more liberal, as well ensuring the homepage is about:blank. Still nothing.

It seems like my problem is now AOL pagetest with IE8 running on windows 2008 (amazon ec2 version)

Here’s my urlblast.ini where I’m able to get IE to start, but hangs at about:blank.
Test Type=4
Startup Delay=2
Log File=C:\Users\Administrator\Desktop\Web Site\log\log
Thread Count=1
Reboot Interval=0
Clear Cache Interval=30
Exit runs=0
; Where to get work from
Url Files Url= ### URL changed for posting to forums.
Location Key=TestKey123
; browser=pagetest.exe
; browser=C:\Users\Administrator\Desktop\Web Site\PageTest.exe

Any assistance or insights would be greatly appreciated. Sorry for the loquacious post, just trying to be thorough.



Make sure you are using the urlblast and pagetest from the 1.9 webpagetest installer (should be newer than 209).

That said, the behavior you are seeing sounds like a folder permissions problem - make sure the log file directory is writable by everyone. Older builds of pagetest would write to the central log and are run in the context of a low-permissions user.