Server and client on same machine for private instance

I followed the steps ( to setup private instance on my local machine running Windows 7.

I tried for testing performance but it remained in “Waiting” stage for more than 30 min. And doesn’t go to Testing → Done stage. I am newbie and might have missed something. Can someone please help me what could be wrong here?


My guess is either urlblast or wptdriver isn’t collecting the job - most probably due to a mismatch between locations.ini and urlblast.ini or wptdriver.ini (depending on what browser you are using)

Check that the agents are connecting ok via and

You should also get an entry in the Apache logs everytime they connect.

Thanks Andy for your reply.

I am testing on IE. The locations.ini looks like



browser=IE 9
label=“Local - IE 9”

And utlBlast.ini looks like

Startup Delay=30
Log File=c:\wpt-agent\urlblast
use current account=1

Url Files Url=

And not sure what this output signifies when i ran

Location Idle Testers Total Tests Being Tested High Priority P1 P2 P3 P4 P5 P6 P7 P8 P9
Local-URLBlast 0 3 0 3 0 0 0 0 0 0 0 0 0

And when i ran, i got
Local-URLBlast ( minutes)

Hmm your config looks exactly like mine but there’s obviously something not quite right as the agent isn’t connecting.

From getLocations you can see there are three tests in the queue but no idle testers or any tests running.

getTesters should return a list of testers along with details of when they last checked for work.

Do you have an entry like this is your Apache log? - - [26/Jun/2013:15:59:01 +0100] "GET /work/getwork.php?shards=1&video=1&location=Local-URLBlast&key=&pc=WPTWIN7&ver=355&freedisk=128.031&ie=9.10.9200.16614&dns= HTTP/1.1" 200 -

Yes, I can see entry in apache log like

2013-06-26 15:51:56	0	0	130626_YB_3	Local - IE 9 - <b>Cable</b>	0			0		b6d33404dfee2b664a718f492862c70228abdec8		2

Seems it is not calling getwork, as I see from your log entries.

That’s not the Apache log that’s the log from WPT.

Your Apache logs will be in something like C:\Program Files\Apache Software Foundation\Apache2.2\logs if you’re on Windows

Apache log access.log has something like this - - [26/Jun/2013:12:50:16 -0400] "GET /pagestyle.css?v=59 HTTP/1.1" 304 - - - [26/Jun/2013:12:50:16 -0400] "GET /js/site.js?v=28 HTTP/1.1" 304 - - - [26/Jun/2013:12:50:16 -0400] "GET /js/test.js?v=25 HTTP/1.1" 304 - - - [26/Jun/2013:12:50:16 -0400] "GET /images/logo_private.png HTTP/1.1" 304 - - - [26/Jun/2013:12:50:19 -0400] "POST /runtest.php HTTP/1.1" 302 - - - [26/Jun/2013:12:50:19 -0400] "GET /result/130626_D5_4/ HTTP/1.1" 200 7408

I dont see any trace of getting request to getwork.php

OK, to ask some ‘daft’ questions.

  1. In what folder is urlblast installed?

  2. Is the urlblast.ini in the same folder?

  3. Is urlblast.exe actually running?

Thanks Andy for your replies. Please see below answers

  1. utlblast installed at C:\wpt-agent
  2. urlblast.ini is in same folder
  3. I didnt start that manually. And this is the reason I was in waiting state. Thanks a lot for helping me out finding this.

Now I am getting this result:
The test completed but there were no successful results.
And there is nothing in the waterfall or screenshot.
And FirstView: Test data missing.

If you watch the screen while the test is running do you see the page load in the browser?

If you enter do you have gzip and the GD modules installed?

Also make sure you installed dummynet. That is the most common cause for “The test completed but there were no successful results”

Hi Andy,
I dont see page loading - I mean testing page, here, is getting loaded in browser. After starting test i see it waits for some time in waiting state and in less than second the test got completed with result as mentioned below.

I do see gzip and GD modules of PHP installed.Curl and APC are not.

Hi Pat,
Thanks for pointing out dummynet. I will check whether that dummynet is installed properly.

At last I got it working on local. The issue was Dummy Net was not installed properly. Thanks Pat and Andy for your help.

I am having same problem for wptdriver. i can see - - [25/Sep/2013:16:28:11 -0500] “GET /work/getwork.php?shards=1&location=Local-WPTDriver&software=wpt&ver=124&pc=DEVPERFORMANCE& HTTP/1.1” 200 -

results are blank

Did you install dummynet? What does wptdriver.ini and locations.ini look like? Are the browser paths in wptdriver.ini correct?