testing nginx - page not loading

any idea why my site doesn’t appear?

this is my first nginx server…
page doesn’t display in http://www.webpagetest.org/result/130826_GE_6Y2/

Page shows up in some, but not all, other online tools. Ex, here is shows up

here is fails

Looks like something is seriously screwed up on the server but it’s impossible to tell from the outside. I’d recommend looking at your logs and firewall configs.

I ran 3 runs and it looks like one eventually worked (though it took > 70 seconds for the base page): http://www.webpagetest.org/result/130826_X0_99f8e9034f21905b256e4f1102d0e52d/

Looking at the tcpdump for one of the failed runs, the HTTP response for the base page is not HTTP: CS Personal on cloudshark.org (frame #44 is the first bit of the response).

Nice one, Patrick! Indeed nginx config was screwed up. Moving index.php to the end of this line, from someplace in the middle, fixed things

[code]server {
listen 80;
listen [::]:80 default_server ipv6only=on;

root /usr/share/nginx/html;
index index.html index.htm index.php;[/code]

Have moved the server to digitalocean.com and, on the first day or using it, was getting pop up messages saying they were under a ddos attack.

Anyway, here is the result

The server is supposed to be in Holland but the results say Russia. ??
another strange lag after first request:

any idea what could cause the lag? the html is a simple static file.
other results:
with css removed

with css removed and a bunch of divs removed

nginx + varnish