Scripts don't go beyond first step

(thread migrated from sourceforge forum - originally posted 2/19/2009)

I’m trying to run a script to simply go through a path and it does not go beyond first step.

I tried the example given in the docs for Hosted Scripting ( and still the same result.

This is great functionality and I’ll probably install local version just to use it, but it’d be great if it worked on a hosted version as well.

BTW, great job! I’m using it often and enjoy! - will definitely mention it in my Web Performance presentation I’m going to give in March.

Thank you,


The hosted version can run a multi-step script but it can only currently display the results from one of the steps (haven’t figured out how best to display multiple steps in the UI). You need to surround the steps that you don’t want the results for by:

logdata 0

logdata 1

(with tabs instead of spaces but I couldn’t post that) which will disable the output of results for intermediate steps.

If you want to see the performance of multiple steps then you need to run them as separate tests.

I do plan on getting full multi-step script support working on the hosted site at some point but have other things ahead of fit in the priority list.