Unable to render video playback

I’m using Centos 7 and have installed webpagest v2.19. Film strip & waterfall seem to be working but not the video playback. The video is created on the server, however, I’m not able to play it on the browser. I can’t even download the video from that page.

The test agent has wptdriver and urlblast running

I tried ‘scp’ the video to my computer and the video played fine with VLC player.

The installation check page indicates that everything installed correctly.

Kindly help.

Hi Pat,

Do you have any suggestions as to why I might be seeing this problem ? Any pointers would be appreciated.

Do you have flash? I would inspect the area around:

<div id="player" ...

within <param name=“flashvars”

the value contains the URL for the video, e.g. www.webpagetest.org%2Fresults%2Fvideo%2F16%2F09%2F26…

I would urldecode that via https://urldecode.org/ and then see if you can hit the video url directly without flash.

Thank you for your response @deshawnbw
Yes, i have flash installed. I tried hitting the video url directly and I could not reach it. The browser kept waiting

I have webpagetest running on a docker container on port 8089

Attached is the screenshot of view source.

Could someone help me figure this out?
I’m unable to reach the video resource as my browser keeps spinning.
But as specified above, the video links are correct within the html.

How can I debug this? Is it a permission issue? Host machine is a centos 7 has a user that is ‘centos’, while the container runs with user ‘www-data’ (as specified in the webpagetest source code Docker file)

Similarly, when I capture dev tools timeline, and click on the timeline result,
I see a blank page:

However,the trace renders correctly

Not sure whats going on here.