Video Keeps buffering in Visual Comparison Page

After running the test I try to watch the video of the run but the video keeps buffering and the server doesn’t reply.


  • Server: Default settings with only locations.ini modified
  • Agent: New python agent with all the dependencies installed

Things I have tried:

  • Re-installing ImageMagick, ffmpeg according to this thread: WebPageTest Forums
  • Changing Apache2 conf to allow mp4 files (didn;t work)
  • Configure read/write permissions to allow user (www-data) to access the directory

The weird part is that I can access video.png/labels.txt files for a given test. The video is created and stored on the server as well but i cannot play it via the browser. However, I can copy the video via ssh (scp) to my computer and play it just fine.

Any help would be appreciated. Thanks

My guess is it is still trying to use the flash-based player. Are you running a local install or using the server AMI (server AMI is updated from github but if you did a manual install it may be slightly out of date). I changed the player over to only use a html5 player a few months ago which hopefully fixes the issue you are seeing. I’ll see about cutting a new official release this week.

If the video is there then the server is generating it fine and it’s likely just a player issue.

EDIT: To answer your question, I am using a manual install (deployed using docker on AWS). Due to company policy I can’t use the public AMI.

Hopefully it fixes the issue. But its weird that I can’t even access the video.mp4 file directly using the URL, not only via player.

oh, that’s not going to be the player then. The player just sources the video from the test result directory directly. Does anything show up in the web server error logs for fetching the video?

Sorry, check that, the video download goes through a php file. i.e.:

Yes. I tried going to the create.php first which redirects to view.php (or download.php to download) but even then it doesn’t play/download. The logs dont show anything suspicious. The request for the video just stays in pending state. I copied over the settings/configurations for our current WPT v2.19 to the newer one, it still doesn’t work.