Waiting at the front of the queue...

I have setup a private WPT instance (the apache front end). Currently have not done any private agents. The locations.ini file are currently pointing to the public locations (Dulles, Chicago, San jose, etc). When I run any test it just sits at the “Waiting at the front of the queue…” Is this setup possible ? If it is what could be the issue?

You can’t run a private instance of the web UI and have it communicate with the public instance. The agents poll the web server for work and the public agents are tied to the public instance.

You can use the EC2 AMI’s if you don’t want to stand up your own dedicated servers: https://sites.google.com/a/webpagetest.org/docs/private-instances#TOC-EC2-Test-Agents

Ok that would explain it. Looking at the page if we do use the AMI what ports should be opened for this to work properly? I assume 3389 for RDP and 80 ? Also What would be the pass to log into the AMI?

The test machines all connect outward to the server so for normal operation you don’t need any ports open on the AMI’s themselves (but you do need port 80 open on the server and connectivity to the server from the AMI’s).

If you do want to log into the AMI you’ll need 3389 open and the Administrator password is “2dialit”

Thanks for the reply. Yep I got it all worked out. Thanks again for all your help and bit of hand holding.