Waterfall graphs not showing plus a possible bug fix

I’ve spent a fair bit of time trying to get webpagetest 3.0 work on Window 10 64 bit. By modifying the code I’ve gotten it to run, but waterfall graphs aren’t showing.


// Load the test-specific data $id = ''; if (preg_match('/^[a-zA-Z0-9_]+$/', @$_REQUEST['test'])) { $id = $_REQUEST['test']; } elseif (preg_match('/^[a-zA-Z0-9_]+$/', @$_COOKIE['tid'])) { $id = $_COOKIE['tid']; }

There’s no header ‘test’ so $id is set to “tid”, which is set to 38aed79c93a067e379b10bf3c4f17d8a3519d296.

If I replace that code with this the test runs and returns a result

$id = substr($_SERVER['REQUEST_URI'], 8, 42);

I wonder, however, if this causes other problems.

waterfall graphs
The waterfall graphs aren’t showing. I get a spinning circle, with nothing loading.

When I copy the image URL ( ) I get another copy of the results page. When I instead hit this URL directly ( thumbnail.php?test=170928_RP_0a8f397ea7be717fae0c369ebdd12cdf&run=1&file=1_waterfall.png ) I get a black featureless png generated.

This suggests that there’s two problems

  1. A problem with the .htaccess rules.
  2. A problem generating the PNG

When I click the waterfall graph to go to the detail view I get back to the original page.

The troubleshooting guide says:
[]Waterfall charts are missing
Check if the GD library is installed. The GD library is used for drawing the waterfalls and generating thumbnail images.
]Look to see if php-zip, php5-zip or a similar zip library is installed. With some default PHP distributions the library is not present.

When I look at phpinfo() I can see
[]“GD Support” is “enabled”
]“GD Version” is “bundled (2.1.0 compatible)”
[]“PNG Support” is enabled
]“libPNG Version” is 1.5.26
[]Zip is enabled
]Zip version 1.12.5
[*]Libzip version is 0.11.2

Any help would be appreciated.

I’m running WAMP 3.0, which includes:
[]Apache apache2.4.27
]PHP 5.6.31

I intend to write a blog post that sets out how I set up the 3.0 private instance on my technical blog in order to help others, if I can get it working.

About the waterfall graphs, I would assume we’re talking about Google Chrome browser here? If so, is it Desktop, Android, iOS?

Yes, I’m using Google Chrome. The client and webpagetest server are both Windows 10 enterprise, with the server in VirtualBox with a bridged network adapter. It’s Chrome desktop. I’m running the tests with default settings.

If I recall correctly, I ran into that issue with Android Chrome, and I think I solved it by installing the PHP mbstring module.

I use Ubuntu, not Windows, but perhaps you might want to check you have all the PHP modules installed. These are the ones I set up.


Also, which wptagent are you running, JS version or Python version? If it’s the former, I would suggest you switch to the latter; you will need to fetch it from GitHub - catchpoint/WebPageTest.agent: Cross-platform WebPageTest agent. You can then run it with the -vvvv option to see if it reports any errors.